Report Designer - Object reference error

I am trying to create/edit reports and get the following error: Object reference not set to an instance of an object. Note that I have created/edited reports before and those that I have done still work. However, any new ones get the same error. I even tested by simply changing a label only off of a report format where I have a custom report already – invoices. Again, I am still able to run the custom reports I had done earlier just unable to create/edit new ones – I want to say last time I did the report designer was August 2018.

I am testing with version 8.3.1417.124 and downloaded the designer directly from the Avontus website so all versions should be current/matching.

Hi Michelle. Sorry about this, we’ll take a look and fix this.

Hi Michelle. Sorry for the hassle. If you update now you should be up and going.

Avontus Dev

I am still getting the same error. image

All I have done is edit a label field to test out the latest version. Again, I can still run earlier versions of reports that have been edited/created.

Hi Michelle. We’re not able to reproduce this. The version I’m using is 8.3.1406.45. I’m guessing that maybe your version isn’t updating for some reason? You’ll see this on the login page above the cancel button. If it’s not the most current can you try uninstall and reinstall? If it is current, can you let me know what it is you’re doing to cause the crash? I’ve added a label and changed the binding and it worked fine.

Avontus Dev

Here is a screen shot of the versions

Right now I am simply doing a label change on invoices. Figured this was the best since it didn’t require any linkage to tables but simply a text field.

Hello Michelle.

Would it be possible to send a copy of your database into our support department? If you can make a backup and send it here:

When you send the file just put a message in the comment there that it’s for an issue on the API forum and they’ll let us know.

Avontus Dev

Yes - I will have it scheduled to copy for the week of the 25th of March. Right now the error is presented in all our database environments and we are scheduled to have all our live instances updated to the latest versions. However, note that the instances i have submitted to you have been with our updated testing environment that is up to the latest versions. Wanted to make sure we had all items working before updating but we can wait to have the report designer looked at within the live environments. One it is updated will test again in the LIVE environment and send a copy.

We tried uploading and got the following:


Note we have already compressed the file as well.

Hi Michelle. Can you contact for this? They should be able to help. Thanks.

Our database has been uploaded. If you could let us know what the issue is as I had to edit one of our live documents and now it does not work as it states the same error.

Thanks, we’ll take a look.

Hi Michelle. This issue is resolved and is included in the next version of Quantify, that you should soon be able to update to. Thank you for posting.

Hi Michelle, just as an update here, might be another week or so before we have a release out to you but we’re working on it. It turns out that the EURD (end-user report designer) has a newer version of some reporting components that aren’t in core Quantify. This has caused a mismatch in the report definitions that core Quantify doesn’t recognize. We’ll also look to getting a version out to you sooner.

Just wanted to see if there was an update on this and/or when can we expect the newer version availability

Thanks Michelle, yes, still working on a release. Hopefully this week.

Just trying to coordinate with other team members on the update. Do you have an ETA yet?

Hi Michelle. We’ve decided to squeeze in a few more fixes, which has delayed things a little. Shouldn’t be later than the end of next week. We’ll provide a version for you that you can make available to your end-users.

Hi Michelle. Just to let you know we did a release last week that fixes your issue. Can you download the latest version of Quantify, version 8.3.1433, as well as the end-user report designer and let us know if all is OK?